趣味のプログラム工房

Coldfusion9の延命 windows2016、2019など

Coldfusion9は最新のIISには対応していません。
※Coldfusion10については、
c:/coldfusion10/cfusion/bin/connectors/IIS_Connector.bat
のバッチで手動でいけるらしい


なので、最新のWindowsOSで使う場合は、Coldfusion自体をバージョンアップするのが、通常の方法です。
が、諸事情で、古いColdfusionをそのまま使いたい場合があると思います。

何とか延命する方法ですが、、、一つの解決策として、IISでの運用をあきらめる!
Coldfusion9が最新のOSで使えないのはインストーラーが対応していないから。
(特にconnector installerが使えない。IISとCFがつながらない)

ですが、ColdfusionをTomcatにデプロイすることで、あたしいOSでも使えるようになります!
が、、、Cookieの扱いとか、若干違って調整が必要になります。

まあ、最新のOSでCF9をつかうなんていうのは最終手段です。

2020年09月22日